VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetProperty: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 40: Line 40:
strIfcPropValue
strIfcPropValue
TXString
TXString
Value
Value.
</line>
</line>
</lineList>
</lineList>

Revision as of 10:19, 21 May 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Sets a property with the provided value.

VCOMError IFC_SetProperty(
MCObjectHandle hObject,
const TXString& strIfcPsetName,
const TXString& strIfcPropName,
const TXString& strIfcPropValue);

Parameters

hObject MCObjectHandle Handle to object.
strIfcPsetName TXString Property Set name/Entity name.
strIfcPropName TXString Property name.
strIfcPropValue TXString Value.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2018.