VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetProperty: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


...put some description here...
Sets a property with the provided value.
</desc>
</desc>


Line 25: Line 25:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
Handle to object.
</line>
</line>
<line>
<line>
strIfcPsetName
strIfcPsetName
TXString
TXString
no info.
Property Set name/Entity name.
</line>
</line>
<line>
<line>
strIfcPropName
strIfcPropName
TXString
TXString
no info.
Property name.
</line>
</line>
<line>
<line>
strIfcPropValue
strIfcPropValue
TXString
TXString
no info.
Value
</line>
</line>
</lineList>
</lineList>
Line 54: Line 54:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 81: Line 77:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2018.
</version>
</version>



Revision as of 09:57, 21 May 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Sets a property with the provided value.

VCOMError IFC_SetProperty(
MCObjectHandle hObject,
const TXString& strIfcPsetName,
const TXString& strIfcPropName,
const TXString& strIfcPropValue);

Parameters

hObject MCObjectHandle Handle to object.
strIfcPsetName TXString Property Set name/Entity name.
strIfcPropName TXString Property name.
strIfcPropValue TXString Value

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2018.