VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetIFCScheme: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationVCOM|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <...")
 
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


...put some description here...
Sets IFC Scheme for the project.
</desc>
</desc>


Line 25: Line 25:
scheme
scheme
EIFCSupportSchema  
EIFCSupportSchema  
no info.
Possible values are <b>kIFCSupportScheme_2x2</b> (IFC 2x3); <b>kIFCSupportScheme_2x3</b> (IFC 2x3) and <b>kIFCSupportScheme_2x4</b> (IFC 4)</line>
</line>
</line>
</lineList>
</lineList>
Line 39: Line 39:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
kVCOMError_Failed
kVCOMError_Failed
Routine failed.
The function failed.
</line>
</line>
</lineList>
</lineList>
Line 62: Line 58:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:Extension:IIFCSupport::SetIFCScheme|IIFCSupport::SetIFCScheme]]
</seeAlso>
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2017
</version>
</version>



Revision as of 11:50, 23 March 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Sets IFC Scheme for the project.

VCOMError IFC_SetIFCScheme(
EIFCSupportSchema scheme);

Parameters

</line>

scheme EIFCSupportSchema Possible values are kIFCSupportScheme_2x2 (IFC 2x3); kIFCSupportScheme_2x3 (IFC 2x3) and kIFCSupportScheme_2x4 (IFC 4)

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed The function failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017

See Also

IIFCSupport::SetIFCScheme

[[VCOM:VectorWorks:Extension:IIFCSupport::SetIFCScheme|IIFCSupport::SetIFCScheme]]