VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetIFCScheme: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationVCOM|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <...")
 
No edit summary
 
(6 intermediate revisions by 2 users not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Sets IFC Scheme for the project.
</desc>
</desc>


Line 24: Line 24:
<line>
<line>
scheme
scheme
EIFCSupportSchema  
[[VCOM:VectorWorks:IFCLib:IFCEnumerations|EIFCSupportSchema]]
no info.
Possible values are <b>kIFCSupportScheme_2x2</b> (IFC 2x2); <b>kIFCSupportScheme_2x3</b> (IFC 2x3) and <b>kIFCSupportScheme_2x4</b> (IFC 4)
</line>
</line>
</lineList>
</lineList>
Line 39: Line 39:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
kVCOMError_Failed
kVCOMError_Failed
Routine failed.
The function failed.
</line>
</line>
</lineList>
</lineList>
Line 62: Line 58:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:IFCLib:IIFCSupport::SetIFCScheme|IIFCSupport::SetIFCScheme]]
</seeAlso>
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2017
</version>
</version>


</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|IFC_SetIFCScheme]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|IFC_SetIFCScheme]]

Latest revision as of 15:00, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Sets IFC Scheme for the project.

VCOMError IFC_SetIFCScheme(
EIFCSupportSchema scheme);

Parameters

scheme EIFCSupportSchema Possible values are kIFCSupportScheme_2x2 (IFC 2x2); kIFCSupportScheme_2x3 (IFC 2x3) and kIFCSupportScheme_2x4 (IFC 4)

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed The function failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017

See Also

IIFCSupport::SetIFCScheme

[[VCOM:VectorWorks:IFCLib:IIFCSupport::SetIFCScheme|IIFCSupport::SetIFCScheme]]