VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetIFCProperty

From Vectorworks Developer
Revision as of 13:32, 19 June 2018 by Sasha (talk | contribs)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Sets the value of entity property.

VCOMError IFC_SetIFCProperty(
MCObjectHandle hObject,
const TXString& instancePropertyValue,
TXString& outSetValue);

Parameters

hObject MCObjectHandle Handle to the object.
instancePropertyValue TXString The parameter must be in following syntax: "<entity_name>.<property_name>=<value>".
outSetValue TXString Ooutput parameter and it contains the result.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_False Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017