VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetIFCEntity2

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Attaches IFC instance to the object.

virtual VCOMError IFC_SetIFCEntity2(
MCObjectHandle hObject,
const TXString& strIfcObjName)

Parameters

hObject MCObjectHandle Handle to the object.
strIfcObjName const TXString& Entity name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_Failed The function failed.
kVCOMError_NoError The function succeeded. No Error!

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2018.