VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetIFCEntity2: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationVCOM|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- ...")
 
No edit summary
Line 10: Line 10:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


<font color="green">Use this functiong via global pointer gIFC.</font>
<font color="green">Use this function via global pointer gIFC.</font>


Attaches IFC instance to the object.
Attaches IFC instance to the object.

Revision as of 12:47, 12 January 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Use this function via global pointer gIFC.

Attaches IFC instance to the object.

virtual VCOMError IFC_SetIFCEntity2(
MCObjectHandle hObject,
const TXString& strIfcObjName)

Parameters

hObject MCObjectHandle Handle to the object.
strIfcObjName const TXString& Entity name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_Failed The function failed.
kVCOMError_NoError The function succeeded. No Error!

Version

Availability: from Vectorworks 2018