VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetIFCEntity2: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(One intermediate revision by the same user not shown)
Line 1: Line 1:
{{LocationMain|category=LocationVCOM|specific=}}
{{LocationMain|category=LocationVCOM|specific=}}
__TOC__
__TOC__
<vwDoc>
<vwDoc>
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Line 9: Line 7:


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]
<font color="green">Use this function via global pointer gIFC.</font>


Attaches IFC instance to the object.
Attaches IFC instance to the object.
Line 58: Line 54:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Use this function via global pointer gIFC.
</remark>
</remark>



Latest revision as of 15:21, 13 July 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Attaches IFC instance to the object.

virtual VCOMError IFC_SetIFCEntity2(
MCObjectHandle hObject,
const TXString& strIfcObjName)

Parameters

hObject MCObjectHandle Handle to the object.
strIfcObjName const TXString& Entity name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_Failed The function failed.
kVCOMError_NoError The function succeeded. No Error!

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2018.