VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetIFCEntity

From Vectorworks Developer
Revision as of 08:07, 5 April 2018 by Sasha (talk | contribs)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Attaches IFC Entity Record to the object.

VCOMError IFC_SetIFCEntity(
MCObjectHandle hObject,
const TXString& strIfcObjName);

Parameters

hObject MCObjectHandle The name of the object.
strIfcObjName TXString IFC Entity type.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.