VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetIFCEntity: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


Attaches IFC Record to the object.
Attaches IFC Entity Record to the object.
</desc>
</desc>


Line 25: Line 25:
hObject
hObject
MCObjectHandle
MCObjectHandle
Object's name.
The name of the object.
</line>
</line>
<line>
<line>

Revision as of 09:07, 22 February 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Attaches IFC Entity Record to the object.

VCOMError IFC_SetIFCEntity(
MCObjectHandle hObject,
const TXString& strIfcObjName);

Parameters

hObject MCObjectHandle The name of the object.
strIfcObjName TXString IFC Entity type.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Use this function via global pointer gIFC.

Version

Vectorworks 12