VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetIFCEntity: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
Line 72: Line 72:
</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|IFC_SetIFCEntity]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|IFC_SetIFCEntity]]

Revision as of 08:07, 5 April 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Attaches IFC Entity Record to the object.

VCOMError IFC_SetIFCEntity(
MCObjectHandle hObject,
const TXString& strIfcObjName);

Parameters

hObject MCObjectHandle The name of the object.
strIfcObjName TXString IFC Entity type.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.