VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetIFCEntity: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
(10 intermediate revisions by 3 users not shown)
Line 1: Line 1:
{{LocationMain|category=LocationVCOM|specific=}}
{{LocationMain|category=LocationVCOM|specific=}}
__TOC__
__TOC__
<vwDoc>
<vwDoc>
Line 8: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Attaches IFC Entity Record to the object.
</desc>
</desc>


Line 16: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual VCOMErrorVCOM_CALLTYPE IFC_SetIFCEntity(MCObjectHandle hObject, const TXString& strIfcObjName) = 0;
VCOMError IFC_SetIFCEntity(MCObjectHandle hObject, const TXString& strIfcObjName);
</funcDef>
</funcDef>
</def>
</def>
Line 26: Line 25:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
The name of the object.
</line>
</line>
<line>
<line>
strIfcObjName
strIfcObjName
const [[SDK:TXString]]&
TXString
no info.
IFC Entity type.
</line>
</line>
</lineList>
</lineList>
Line 43: Line 42:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
kVCOMError_NotInitialized
kVCOMError_Failed
Bad VCOM instance used to call the fuction.
Routine failed.
</line>
</line>
<line>
<line>
kVCOMError_Failed
kVCOMError_NoError
Routine failed.
Routine succeeded.
</line>
</line>
</lineList>
</lineList>
Line 55: Line 54:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Use this function via global pointer gIFC.
</remark>
</remark>


Line 67: Line 67:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 12.
</version>
</version>



Latest revision as of 15:04, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Attaches IFC Entity Record to the object.

VCOMError IFC_SetIFCEntity(
MCObjectHandle hObject,
const TXString& strIfcObjName);

Parameters

hObject MCObjectHandle The name of the object.
strIfcObjName TXString IFC Entity type.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.