VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetFieldType

From Vectorworks Developer
Revision as of 15:28, 19 June 2018 by NBeshevliev (talk | contribs)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Sets the type of an IfcEntity field or Property Set(PSet) field Mapped to that IfcEntity.

VCOMError IFC_SetFieldType(
const TXString& strObjectName,
const TXString& strEntryName,
const TXString& strFieldName,
const short& enType,
const TXString& strPSetName = "");

Parameters

strObjectName TXString Object name.
strEntryName TXString IfcEntity name.
strFieldName TXString Field name.
enType short Field type. Possible values are represented by EIfcType
strPSetName TXString PSet name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019


Categories: VCOM:VectorWorks:IFCLib:IIFCSupport