VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetFieldType: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(3 intermediate revisions by one other user not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Sets the type of an IfcEntity field or Property Set(PSet) field Mapped to that IfcEntity.
</desc>
</desc>


Line 15: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
VCOMError IFC_SetFieldType(const TXString& strObjectName, const TXString& strEntryName, const TXString& strFieldName, const short& enType);
VCOMError IFC_SetFieldType(const TXString& strObjectName, const TXString& strEntryName, const TXString& strFieldName, const short& enType, const TXString& strPSetName = "");
</funcDef>
</funcDef>
</def>
</def>
Line 25: Line 25:
strObjectName
strObjectName
TXString
TXString
no info.
Object name.
</line>
</line>
<line>
<line>
strEntryName
strEntryName
TXString
TXString
no info.
IfcEntity name.
</line>
</line>
<line>
<line>
strFieldName
strFieldName
TXString
TXString
no info.
Field name.
</line>
</line>
<line>
<line>
enType
enType
short
short
no info.
Field type. Possible values are represented by [[VCOM:VectorWorks:IFCLib:IFCEnumerations|EIfcType]]
</line>
<line>
strPSetName
TXString
PSet name.
</line>
</line>
</lineList>
</lineList>
Line 54: Line 59:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 81: Line 82:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2019
</version>
</version>



Latest revision as of 16:57, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Sets the type of an IfcEntity field or Property Set(PSet) field Mapped to that IfcEntity.

VCOMError IFC_SetFieldType(
const TXString& strObjectName,
const TXString& strEntryName,
const TXString& strFieldName,
const short& enType,
const TXString& strPSetName = "");

Parameters

strObjectName TXString Object name.
strEntryName TXString IfcEntity name.
strFieldName TXString Field name.
enType short Field type. Possible values are represented by EIfcType
strPSetName TXString PSet name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019