VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetFieldMapping: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
(2 intermediate revisions by 2 users not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Sets the mapping for the specified field.
</desc>
</desc>


Line 25: Line 25:
strObjectName
strObjectName
TXString
TXString
no info.
Object name.
</line>
</line>
<line>
<line>
strEntryName
strEntryName
TXString
TXString
no info.
IFC entity name.
</line>
</line>
<line>
<line>
strFieldName
strFieldName
TXString
TXString
no info.
Field name.
</line>
</line>
<line>
<line>
strValue
strValue
TXString
TXString
no info.
Mapping value.
</line>
</line>
</lineList>
</lineList>
Line 54: Line 54:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 81: Line 77:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2018.
</version>
</version>


</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|IFC_SetFieldMapping]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|IFC_SetFieldMapping]]

Latest revision as of 14:17, 14 September 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Sets the mapping for the specified field.

VCOMError IFC_SetFieldMapping(
const TXString& strObjectName,
const TXString& strEntryName,
const TXString& strFieldName,
const TXString& strValue);

Parameters

strObjectName TXString Object name.
strEntryName TXString IFC entity name.
strFieldName TXString Field name.
strValue TXString Mapping value.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2018.