VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetFieldEnabled

From Vectorworks Developer
Revision as of 13:24, 18 May 2018 by NBeshevliev (talk | contribs)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Set the IFC Data Mapping export status of an Entry field. If the field is disabled the it won't be exported. This is valid also for PSet field. (The PSet must belong to that Entry in the IFC Data Mapping)

VCOMError IFC_SetFieldEnabled(
const TXString& strObjectName,
const TXString& strEntryName,
const TXString& strFieldName,
bool bEnable,
const TXString& strPSetName = "");

Parameters

strObjectName TXString Object Name.
strEntryName TXString IfcEntity Name.
strFieldName TXString Field Name.
bEnable bool Include/exclude the field from export.
strPSetName TXString Property Set Name which belongs to the Entry according to IFC Data Mapping.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019