VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetFieldEnabled: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


...put some description here...
Set the IFC Data Mapping export status of an Entry field. If the field is disabled the it won't be exported. This is valid also for PSet field. (The PSet must belong to that Entry in the IFC Data Mapping)
</desc>
</desc>


Line 15: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
VCOMError IFC_SetFieldEnabled(const TXString& strObjectName, const TXString& strEntryName, const TXString& strFieldName, bool bEnable);
VCOMError IFC_SetFieldEnabled(const TXString& strObjectName, const TXString& strEntryName, const TXString& strFieldName, bool bEnable, const TXString& strPSetName = "");
</funcDef>
</funcDef>
</def>
</def>
Line 25: Line 25:
strObjectName
strObjectName
TXString
TXString
no info.
Object Name.
</line>
</line>
<line>
<line>
strEntryName
strEntryName
TXString
TXString
no info.
IfcEntity Name.
</line>
</line>
<line>
<line>
strFieldName
strFieldName
TXString
TXString
no info.
Field Name.
</line>
</line>
<line>
<line>
bEnable
bEnable
bool
bool
no info.
Include/exclude the field from export.
</line>
<line>
strPSetName
TXString
Property Set Name which belongs to the Entry according to IFC Data Mapping.
</line>
</line>
</lineList>
</lineList>
Line 54: Line 59:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 81: Line 82:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2019
</version>
</version>



Revision as of 13:24, 18 May 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Set the IFC Data Mapping export status of an Entry field. If the field is disabled the it won't be exported. This is valid also for PSet field. (The PSet must belong to that Entry in the IFC Data Mapping)

VCOMError IFC_SetFieldEnabled(
const TXString& strObjectName,
const TXString& strEntryName,
const TXString& strFieldName,
bool bEnable,
const TXString& strPSetName = "");

Parameters

strObjectName TXString Object Name.
strEntryName TXString IfcEntity Name.
strFieldName TXString Field Name.
bEnable bool Include/exclude the field from export.
strPSetName TXString Property Set Name which belongs to the Entry according to IFC Data Mapping.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019