VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetFieldEmpty: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


Sets the flag for emptiness in the mapping for the specified object's field.  
Sets the flag for emptiness in the mapping for the specified object's field.  

Latest revision as of 15:21, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Sets the flag for emptiness in the mapping for the specified object's field.

VCOMError IFC_SetFieldEmpty(
const TXString& strObjectName,
const TXString& strEntryName,
const TXString& strFieldName,
bool bEmpty,
const TXString& strPSetName = "");

Parameters

strObjectName TXString Object name
strEntryName TXString IFC Entity name.
strFieldName TXString Field name.
bEmpty bool Field flag.
strPSetName TXString Property Set name. Optional parameter used only when the field is a part of a Property Set.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017.