VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetFieldEmpty: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


...put some description here...
Sets the flag for emptiness in the mapping for the specified object's field.  
</desc>
</desc>


Line 15: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
VCOMError IFC_SetFieldEmpty(const TXString& strObjectName, const TXString& strEntryName, const TXString& strFieldName, bool bEmpty);
VCOMError IFC_SetFieldEmpty(const TXString& strObjectName, const TXString& strEntryName, const TXString& strFieldName, bool bEmpty, const TXString& strPSetName = "");
</funcDef>
</funcDef>
</def>
</def>
Line 25: Line 25:
strObjectName
strObjectName
TXString
TXString
no info.
Object name
</line>
</line>
<line>
<line>
strEntryName
strEntryName
TXString
TXString
no info.
IFC Entity name.
</line>
</line>
<line>
<line>
strFieldName
strFieldName
TXString
TXString
no info.
Field name.
</line>
</line>
<line>
<line>
bEmpty
bEmpty
bool
bool
no info.
Field flag.
</line>
<line>
strPSetName
TXString
Property Set name. Optional parameter used only when the field is a part of a Property Set.
</line>
</line>
</lineList>
</lineList>
Line 54: Line 59:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 81: Line 82:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2017.
</version>
</version>



Revision as of 13:08, 31 May 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Sets the flag for emptiness in the mapping for the specified object's field.

VCOMError IFC_SetFieldEmpty(
const TXString& strObjectName,
const TXString& strEntryName,
const TXString& strFieldName,
bool bEmpty,
const TXString& strPSetName = "");

Parameters

strObjectName TXString Object name
strEntryName TXString IFC Entity name.
strFieldName TXString Field name.
bEmpty bool Field flag.
strPSetName TXString Property Set name. Optional parameter used only when the field is a part of a Property Set.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017.