VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetEntityProp: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


...put some description here...
Sets the property value of an entity property.
</desc>
</desc>


Line 25: Line 25:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
Handle to object.
</line>
</line>
<line>
<line>
strIfcPropName
strIfcPropName
TXString
TXString
no info.
Property name.
</line>
</line>
<line>
<line>
strIfcPropValue
strIfcPropValue
TXString
TXString
no info.
Property value.
</line>
</line>
</lineList>
</lineList>
Line 53: Line 53:
kVCOMError_Failed
kVCOMError_Failed
Routine failed.
Routine failed.
</line>
<line>
kVCOMError_NoError
Routine succeeded.
</line>
</line>
</lineList>
</lineList>
Line 59: Line 63:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Note that this function sets only property fields of entities. For setting property values of Property Sets please use [[VCOM:VectorWorks:Extension:IIFCSupport::IFC SetPsetProp|IFC_GetPsetProp]].
</remark>
</remark>


Line 71: Line 76:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2008.
</version>
</version>



Revision as of 10:30, 5 February 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Sets the property value of an entity property.

VCOMError IFC_SetEntityProp(
MCObjectHandle hObject,
const TXString& strIfcPropName,
const TXString& strIfcPropValue);

Parameters

hObject MCObjectHandle Handle to object.
strIfcPropName TXString Property name.
strIfcPropValue TXString Property value.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Note that this function sets only property fields of entities. For setting property values of Property Sets please use IFC_GetPsetProp.

Version

Available from: Vectorworks 2008.