VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetEntityProp: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(7 intermediate revisions by 2 users not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Sets the property value of an entity property.
</desc>
</desc>


Line 15: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual VCOMErrorVCOM_CALLTYPE IFC_SetEntityProp(MCObjectHandle hObject, const TXString& strIfcPropName, const TXString& strIfcPropValue) = 0;
VCOMError IFC_SetEntityProp(MCObjectHandle hObject, const TXString& strIfcPropName, const TXString& strIfcPropValue);
</funcDef>
</funcDef>
</def>
</def>
Line 25: Line 25:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
Handle to object.
</line>
</line>
<line>
<line>
strIfcPropName
strIfcPropName
const [[SDK:TXString]]&
TXString
no info.
Property name.
</line>
</line>
<line>
<line>
strIfcPropValue
strIfcPropValue
const [[SDK:TXString]]&
TXString
no info.
Property value.
</line>
</line>
</lineList>
</lineList>
Line 53: Line 53:
kVCOMError_Failed
kVCOMError_Failed
Routine failed.
Routine failed.
</line>
<line>
kVCOMError_NoError
Routine succeeded.
</line>
</line>
</lineList>
</lineList>
Line 59: Line 63:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Note that this function sets only property fields of entities. For setting Property Sets fields please use [[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetPsetProp|IFC_SetPsetProp]].
Use this function via global pointer gIFC.
</remark>
</remark>


Line 71: Line 79:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2008.
</version>
</version>


</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|IFC_SetEntityProp]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|IFC_SetEntityProp]]

Latest revision as of 15:04, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Sets the property value of an entity property.

VCOMError IFC_SetEntityProp(
MCObjectHandle hObject,
const TXString& strIfcPropName,
const TXString& strIfcPropValue);

Parameters

hObject MCObjectHandle Handle to object.
strIfcPropName TXString Property name.
strIfcPropValue TXString Property value.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Note that this function sets only property fields of entities. For setting Property Sets fields please use IFC_SetPsetProp.


Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2008.