VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetEntityProp: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 64: Line 64:
<remark>
<remark>
Note that this function sets only property fields of entities. For setting Property Sets fields please use [[VCOM:VectorWorks:Extension:IIFCSupport::IFC SetPsetProp|IFC_SetPsetProp]].
Note that this function sets only property fields of entities. For setting Property Sets fields please use [[VCOM:VectorWorks:Extension:IIFCSupport::IFC SetPsetProp|IFC_SetPsetProp]].
Use this function via global pointer gIFC.
</remark>
</remark>



Revision as of 12:05, 5 February 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Sets the property value of an entity property.

VCOMError IFC_SetEntityProp(
MCObjectHandle hObject,
const TXString& strIfcPropName,
const TXString& strIfcPropValue);

Parameters

hObject MCObjectHandle Handle to object.
strIfcPropName TXString Property name.
strIfcPropValue TXString Property value.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Note that this function sets only property fields of entities. For setting Property Sets fields please use IFC_SetPsetProp.

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2008.