VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetEntityColor

From Vectorworks Developer
Revision as of 11:22, 13 July 2018 by Sasha (talk | contribs)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Sets the color for an IFC entity in RGB format.

VCOMError IFC_SetEntityColor(
const TXString& strIfcName,
short red,
short green,
short blue,
short transparent);

Parameters

strIfcName TXString IFC Entity name.
red short The red component of the color, varies from from 0 to 255.
green short The green component of the color, varies from from 0 to 255.
blue short The blue component of the color, varies from from 0 to 255.
transparent short Flag for transparency. 1 for TRUE, 0 for FALSE.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!

Version

Available from: 2019