VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetEntityColor: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Sets the color for an IFC entity in RGB format.
</desc>
</desc>


Line 25: Line 25:
strIfcName
strIfcName
TXString
TXString
no info.
IFC Entity name.
</line>
</line>
<line>
<line>
red
red
short
short
no info.
The red component of the color, varies from from 0 to 255.
</line>
</line>
<line>
<line>
green
green
short
short
no info.
The green component of the color, varies from from 0 to 255.
</line>
</line>
<line>
<line>
blue
blue
short
short
no info.
The blue component of the color, varies from from 0 to 255.
</line>
</line>
<line>
<line>
transparent
transparent
short
short
no info.
Flag for transparency. 1 for TRUE, 0 for FALSE.
</line>
</line>
</lineList>
</lineList>
Line 57: Line 57:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
kVCOMError_NotInitialized
kVCOMError_NoError
Bad VCOM instance used to call the fuction.
The function succeeded. No Error!
</line>
<line>
kVCOMError_Failed
Routine failed.
</line>
</line>
</lineList>
</lineList>
Line 81: Line 77:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from:  
Available from: 2019
</version>
</version>



Revision as of 11:22, 13 July 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Sets the color for an IFC entity in RGB format.

VCOMError IFC_SetEntityColor(
const TXString& strIfcName,
short red,
short green,
short blue,
short transparent);

Parameters

strIfcName TXString IFC Entity name.
red short The red component of the color, varies from from 0 to 255.
green short The green component of the color, varies from from 0 to 255.
blue short The blue component of the color, varies from from 0 to 255.
transparent short Flag for transparency. 1 for TRUE, 0 for FALSE.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!

Version

Available from: 2019