VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SaveMapSettings: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Saves IFC Data Mappings Settings.
</desc>
</desc>


Line 25: Line 25:
strMappingName
strMappingName
TXString
TXString
no info.
IFC Data Mapping name.
</line>
</line>
<line>
<line>
strObjectName
strObjectName
TXString
TXString
no info.
If the user want to Save the IFC Data Mapping for specified object, must produce it's name.
</line>
</line>
<line>
<line>
bFileSettings
bFileSettings
bool
bool
no info.
If set to True the whole IFC Data Mapping is saved, else - if set to False, is saved only for specified object.
</line>
</line>
</lineList>
</lineList>
Line 49: Line 49:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 76: Line 72:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2017.
</version>
</version>



Latest revision as of 07:02, 25 September 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Saves IFC Data Mappings Settings.

VCOMError IFC_SaveMapSettings(
const TXString& strMappingName,
const TXString& strObjectName,
bool bFileSettings);

Parameters

strMappingName TXString IFC Data Mapping name.
strObjectName TXString If the user want to Save the IFC Data Mapping for specified object, must produce it's name.
bFileSettings bool If set to True the whole IFC Data Mapping is saved, else - if set to False, is saved only for specified object.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017.