VCOM:VectorWorks:IFCLib:IIFCSupport::IFC ResetMapToCOBieDefaults: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
(2 intermediate revisions by 2 users not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Sets the active mapping to <b><COBie Defaults></b>.
</desc>
</desc>


Line 32: Line 32:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 59: Line 55:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2018.
</version>
</version>


</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|IFC_ResetMapToCOBieDefaults]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|IFC_ResetMapToCOBieDefaults]]

Latest revision as of 11:03, 18 September 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Sets the active mapping to <COBie Defaults>.

VCOMError IFC_ResetMapToCOBieDefaults( );

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2018.