VCOM:VectorWorks:IFCLib:IIFCSupport::IFC ReplaceDataWithMapping: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(One intermediate revision by one other user not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Replaces the IFC data attached to an object with the data from the active IFC data mapping.
</desc>
</desc>


Line 25: Line 25:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
Handle to object.
</line>
</line>
<line>
<line>
strObjName  
strObjName  
TXString  
TXString  
no info.
Object name. The default value for this parameter is empty string.  
</line>
</line>
</lineList>
</lineList>
Line 44: Line 44:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 58: Line 54:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Please not that if the provided handle is <b>NULL</b>, then the IFC Data for all objects with object name <b>strObjName</b> is going to be replaced with the data from the active IFC data mapping. If the provided string is <b>"allObjects"</b> then the data for all objects in the file is going to be replaced with the data from the active IFC data mapping.
Use this function via global pointer gIFC.  
Use this function via global pointer gIFC.  
</remark>  
</remark>  
Line 71: Line 70:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2018.
</version>
</version>



Latest revision as of 10:59, 18 September 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Replaces the IFC data attached to an object with the data from the active IFC data mapping.

VCOMError IFC_ReplaceDataWithMapping(
MCObjectHandle hObject,
TXString strObjName = "");

Parameters

hObject MCObjectHandle Handle to object.
strObjName TXString Object name. The default value for this parameter is empty string.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Please not that if the provided handle is NULL, then the IFC Data for all objects with object name strObjName is going to be replaced with the data from the active IFC data mapping. If the provided string is "allObjects" then the data for all objects in the file is going to be replaced with the data from the active IFC data mapping.


Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2018.