VCOM:VectorWorks:IFCLib:IIFCSupport::IFC IsPsetCustom: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(One intermediate revision by one other user not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Returns a boolean that indicates whether a Property set is custom or not.
</desc>
</desc>


Line 25: Line 25:
strPsetName
strPsetName
TXString
TXString
no info.
Pset name.
</line>
</line>
<line>
<line>
bCustom
bCustom
bool
bool
no info.
Return boolean. If the value is <b>true</b> the Property set is custom.
</line>
</line>
</lineList>
</lineList>
Line 44: Line 44:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 71: Line 67:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2018.
</version>
</version>



Latest revision as of 11:22, 27 August 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns a boolean that indicates whether a Property set is custom or not.

VCOMError IFC_IsPsetCustom(
const TXString& strPsetName,
bool& bCustom);

Parameters

strPsetName TXString Pset name.
bCustom bool Return boolean. If the value is true the Property set is custom.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2018.