VCOM:VectorWorks:IFCLib:IIFCSupport::IFC IsObjectEnabled: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Returns a flag that shows whether the provided object is enabled in the current mapping settings.
</desc>
</desc>


Line 25: Line 25:
strObjectName
strObjectName
TXString
TXString
no info.
Object name.
</line>
</line>
</lineList>
</lineList>
Line 41: Line 41:
</line>
</line>
<line>
<line>
kVCOMError_NotInitialized
kVCOMError_False
Bad VCOM instance used to call the function.
The function responded with 'false' (negative)
</line>
</line>
<line>
<line>
Line 62: Line 62:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_EnableObject|IFC_EnableObject]]
</seeAlso>
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2017.
</version>
</version>



Latest revision as of 07:11, 2 July 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns a flag that shows whether the provided object is enabled in the current mapping settings.

VCOMError IFC_IsObjectEnabled(
const TXString& strObjectName);

Parameters

strObjectName TXString Object name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_False The function responded with 'false' (negative)
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017.

See Also

IFC_EnableObject

[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_EnableObject|IFC_EnableObject]]