VCOM:VectorWorks:IFCLib:IIFCSupport::IFC IsIFCRecord

From Vectorworks Developer
Revision as of 08:03, 5 April 2018 by Sasha (talk | contribs)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Returns the record type.

VCOMError IFC_IsIFCRecord(
const TXString& recordName,
ERecordIFCType& outType);

Parameters

recordName TXString Record name.
outType ERecordIFCType The record type. Click on link for more details.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from Vectorworks 2019.