VCOM:VectorWorks:IFCLib:IIFCSupport::IFC IsIFCRecord

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Returns the record type.

VCOMError IFC_IsIFCRecord(
const TXString& recordName,
ERecordIFCType& outType);

Parameters

recordName TXString Record name.
outType ERecordIFCType The record type. Click on link for more details.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from Vectorworks 2019.