VCOM:VectorWorks:IFCLib:IIFCSupport::IFC IsIFCRecord: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationVCOM|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- ...")
 
No edit summary
Line 10: Line 10:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


Check if the record is IFC/COBie record.
Returns the record type.
</desc>
</desc>


Line 16: Line 16:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
bool IFC_IsIFCRecord(MCObjectHandle hRecord);
VCOMError IFC_IsIFCRecord(const TXString& recordName, ERecordIFCType& outType);
</funcDef>
</funcDef>
</def>
</def>
Line 24: Line 24:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
hRecord
recordName
MCObjectHandle
TXString
Handle to a record.  
Record name.
</line>
<line>
outType
[[VCOM:VectorWorks:IFCLib:IFCEnumerations|ERecordIFCType]]
The record type. Click on link for more details.
</line>
</line>
</lineList>
</lineList>
Line 33: Line 38:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<return>
The function returns <b>TRUE</b> if the record is IFC/COBie record. Otherwise returns <b>FALSE</b>.
Uses standard [[VCOM:VCOMError|VCOM Error Reporting]].
 
Return value meaning:
<lineList ident=1>
<line>
kVCOMError_NoError
The function succeeded. No Error!
</line>
<line>
kVCOMError_Failed
Routine failed.
</line>
</lineList>
</return>
</return>



Revision as of 13:26, 3 April 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Returns the record type.

VCOMError IFC_IsIFCRecord(
const TXString& recordName,
ERecordIFCType& outType);

Parameters

recordName TXString Record name.
outType ERecordIFCType The record type. Click on link for more details.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from Vectorworks 2019.