VCOM:VectorWorks:IFCLib:IIFCSupport::IFC IsFieldOptional: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Checks whether the specified object's field is Optional.
</desc>
</desc>


Line 15: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
VCOMError IFC_IsFieldOptional(const TXString& strObjectName, const TXString& strEntryName, const TXString& strFieldName);
VCOMError IFC_IsFieldOptional(const TXString& strObjectName, const TXString& strEntryName, const TXString& strFieldName, const TXString& strPSetName = "");
</funcDef>
</funcDef>
</def>
</def>
Line 25: Line 25:
strObjectName
strObjectName
TXString
TXString
no info.
Object name.
</line>
</line>
<line>
<line>
strEntryName
strEntryName
TXString
TXString
no info.
IFC Entity name.
</line>
</line>
<line>
<line>
strFieldName
strFieldName
TXString
TXString
no info.
Field name.
</line>
<line>
strPSetName
TXString
Property Set name. Optional parameter used only when the field is a part of a Property Set.
</line>
</line>
</lineList>
</lineList>
Line 48: Line 53:
<line>
<line>
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The Field is Optional.
</line>
</line>
<line>
<line>
kVCOMError_NotInitialized
kVCOMError_False
Bad VCOM instance used to call the function.
The Field is NOT Optional.
</line>
</line>
<line>
<line>
Line 76: Line 81:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2019.
</version>
</version>



Latest revision as of 07:07, 25 September 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Checks whether the specified object's field is Optional.

VCOMError IFC_IsFieldOptional(
const TXString& strObjectName,
const TXString& strEntryName,
const TXString& strFieldName,
const TXString& strPSetName = "");

Parameters

strObjectName TXString Object name.
strEntryName TXString IFC Entity name.
strFieldName TXString Field name.
strPSetName TXString Property Set name. Optional parameter used only when the field is a part of a Property Set.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The Field is Optional.
kVCOMError_False The Field is NOT Optional.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019.