VCOM:VectorWorks:IFCLib:IIFCSupport::IFC IsFieldEnabled

From Vectorworks Developer
Revision as of 15:21, 19 June 2018 by NBeshevliev (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Check the IFC Data Mapping export status of an entry'ss field. If the field is disabled the it won't we exported. This is valid for Psets too.

VCOMError IFC_IsFieldEnabled(
const TXString& strObjectName,
const TXString& strEntryName,
const TXString& strFieldName,
const TXString& strPSetName = "");

Parameters

strObjectName TXString The name of the object.
strEntryName TXString The name of the entry.
strFieldName TXString The name of the field.
strPSetName TXString The name of the Pset.

Return Value

Return value meaning:

kVCOMError_NoError The function succeeded AND the field is ENABLED.
kVCOMError_Failed Routine failed.
kVCOMError_False The function succeeded AND the field is DISABLED.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019