VCOM:VectorWorks:IFCLib:IIFCSupport::IFC IsFieldEnabled: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


...put some description here...
Check the IFC Data Mapping export status of an object's Entry. If the entry is disabled the it won't we exported. This is valid for Psets too.
</desc>
</desc>


Line 15: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
VCOMError IFC_IsFieldEnabled(const TXString& strObjectName, const TXString& strEntryName, const TXString& strFieldName);
VCOMError IFC_IsFieldEnabled(const TXString& strObjectName, const TXString& strEntryName, const TXString& strFieldName, const TXString& strPSetName = "");
</funcDef>
</funcDef>
</def>
</def>
Line 25: Line 25:
strObjectName
strObjectName
TXString
TXString
no info.
The name of the object.
</line>
</line>
<line>
<line>
strEntryName
strEntryName
TXString
TXString
no info.
The name of the entry.
</line>
</line>
<line>
<line>
strFieldName
strFieldName
TXString
TXString
no info.
The name of the field.
</line>
<line>
strPSetName
TXString
The name of the Pset.
</line>
</line>
</lineList>
</lineList>
Line 42: Line 47:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<return>
Uses standard [[VCOM:VCOMError|VCOM Error Reporting]].
Return value meaning:
Return value meaning:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded AND the field is ENABLED.
</line>
</line>
<line>
<line>
kVCOMError_NotInitialized
kVCOMError_Failed
Bad VCOM instance used to call the function.
The function succeeded AND the field is DISABLED.
</line>
</line>
<line>
<line>
kVCOMError_Failed
kVCOMError_False
Routine failed.
Bad VCOM instance used to call the function.
</line>
</line>
</lineList>
</lineList>
Line 76: Line 79:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2019
</version>
</version>



Revision as of 15:02, 17 May 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Check the IFC Data Mapping export status of an object's Entry. If the entry is disabled the it won't we exported. This is valid for Psets too.

VCOMError IFC_IsFieldEnabled(
const TXString& strObjectName,
const TXString& strEntryName,
const TXString& strFieldName,
const TXString& strPSetName = "");

Parameters

strObjectName TXString The name of the object.
strEntryName TXString The name of the entry.
strFieldName TXString The name of the field.
strPSetName TXString The name of the Pset.

Return Value

Return value meaning:

kVCOMError_NoError The function succeeded AND the field is ENABLED.
kVCOMError_Failed The function succeeded AND the field is DISABLED.
kVCOMError_False Bad VCOM instance used to call the function.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019