VCOM:VectorWorks:IFCLib:IIFCSupport::IFC IsFieldEmpty: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


...put some description here...
Checks whether there is mapping for the specified object's field.
</desc>
</desc>


Line 15: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual VCOMError VCOM_CALLTYPE IFC_IsFieldEmpty(const TXString& strObjectName, const TXString& strEntryName, const TXString& strFieldName);
virtual VCOMError VCOM_CALLTYPE IFC_IsFieldEmpty(const TXString& strObjectName, const TXString& strEntryName, const TXString& strFieldName,  const TXString& strPSetName = "");
</funcDef>
</funcDef>
</def>
</def>
Line 25: Line 25:
strObjectName
strObjectName
TXString
TXString
no info.
Object Name
</line>
</line>
<line>
<line>
strEntryName
strEntryName
TXString
TXString
no info.
IFC Entity name.
</line>
</line>
<line>
<line>
strFieldName
strFieldName
TXString
TXString
no info.
Field Name
</line>
<line>
strPSetName
TXString
Property Set name. Optional parameter used only when the field is a part of a Property Set.
</line>
</line>
</lineList>
</lineList>
Line 48: Line 53:
<line>
<line>
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. The field is empty.
</line>
</line>
<line>
<line>
kVCOMError_NotInitialized
kVCOMError_False
Bad VCOM instance used to call the function.
The function succeeded. The field is not empty.
</line>
</line>
<line>
<line>
Line 76: Line 81:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2017.
</version>
</version>



Revision as of 10:09, 21 May 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Checks whether there is mapping for the specified object's field.

virtual VCOMError VCOM_CALLTYPE IFC_IsFieldEmpty(
const TXString& strObjectName,
const TXString& strEntryName,
const TXString& strFieldName,
const TXString& strPSetName = "");

Parameters

strObjectName TXString Object Name
strEntryName TXString IFC Entity name.
strFieldName TXString Field Name
strPSetName TXString Property Set name. Optional parameter used only when the field is a part of a Property Set.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. The field is empty.
kVCOMError_False The function succeeded. The field is not empty.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017.