VCOM:VectorWorks:IFCLib:IIFCSupport::IFC IsFieldEmpty: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(One intermediate revision by one other user not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


Checks whether there is mapping for the specified object's field.
Checks whether there is mapping for the specified object's field.
Line 25: Line 25:
strObjectName
strObjectName
TXString
TXString
Object Name.
Object name.
</line>
</line>
<line>
<line>
Line 35: Line 35:
strFieldName
strFieldName
TXString
TXString
Field Name.
Field name.
</line>
</line>
<line>
<line>

Latest revision as of 15:21, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Checks whether there is mapping for the specified object's field.

virtual VCOMError VCOM_CALLTYPE IFC_IsFieldEmpty(
const TXString& strObjectName,
const TXString& strEntryName,
const TXString& strFieldName,
const TXString& strPSetName = "");

Parameters

strObjectName TXString Object name.
strEntryName TXString IFC Entity name.
strFieldName TXString Field name.
strPSetName TXString Property Set name. Optional parameter used only when the field is a part of a Property Set.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. The field is empty.
kVCOMError_False The function succeeded. The field is not empty.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017.