VCOM:VectorWorks:IFCLib:IIFCSupport::IFC IsEntryEnabled

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns a flag that shows whether the provided IfcEntity for specified Object is enabled in the current mapping settings.

VCOMError IFC_IsEntryEnabled(
const TXString& strObjectName,
const TXString& strEntryName);

Parameters

strObjectName TXString Object name.
strEntryName TXString IfcEntity name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019.