VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetSpaceParamForObject2: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 60: Line 60:
<remark>
<remark>
Please note that if the object is not situated in a space object the routine is going to fail.  
Please note that if the object is not situated in a space object the routine is going to fail.  
Please note that if the object is situated in more than one space objects and the parameters in more that one of them return a value, they will be listed consecutively separated by a coma (',').  
Please note that if the object is situated in more than one space objects and the parameters in more that one of them return a value, they will be listed consecutively, separated by a coma (',').  





Latest revision as of 11:12, 27 August 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns one of three parameters of a space object (Space Name/Space Type/Space Number) in which the specified object is confined or adjoined.

VCOMError IFC_GetSpaceParamForObject2(
MCObjectHandle hObject,
const TXString& param,
TXString& outResult);

Parameters

hObject MCObjectHandle Handle to object.
param TXString Index that determines the return parameter for the space object. The Possible values are: 1 (Space Type), 2 (Space Name) and 3 (Space Number).
outResult TXString The return value of the parameter.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Please note that if the object is not situated in a space object the routine is going to fail.

Please note that if the object is situated in more than one space objects and the parameters in more that one of them return a value, they will be listed consecutively, separated by a coma (',').


Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2018.