VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetRecordLocalizedName

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Returns the localized name of the record.

VCOMError IFC_GetRecordLocalizedName(
MCObjectHandle hFormat,
TXString& outName);

Parameters

hFormat MCObjectHandle Handle to the record.
outName TXString Out parameter for the result.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019.