VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetRecordLocalizedName: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationVCOM|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <...")
 
No edit summary
 
(4 intermediate revisions by one other user not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Returns the localized name of the record.
</desc>
</desc>


Line 15: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
VCOMError FC_GetRecordLocalizedName(MCObjectHandle hFormat, TXString& outName);
VCOMError IFC_GetRecordLocalizedName(MCObjectHandle hFormat, TXString& outName);
</funcDef>
</funcDef>
</def>
</def>
Line 25: Line 25:
hFormat
hFormat
MCObjectHandle
MCObjectHandle
no info.
Handle to the record.
</line>
</line>
<line>
<line>
outName
outName
TXString
TXString
no info.
Out parameter for the result.
</line>
</line>
</lineList>
</lineList>
Line 44: Line 44:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 71: Line 67:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2019.
</version>
</version>


</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|IFC_GetRecordLocalizedName]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|IFC_GetRecordLocalizedName]]

Latest revision as of 15:26, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the localized name of the record.

VCOMError IFC_GetRecordLocalizedName(
MCObjectHandle hFormat,
TXString& outName);

Parameters

hFormat MCObjectHandle Handle to the record.
outName TXString Out parameter for the result.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019.