VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetRecordLocalizedName: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationVCOM|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <...")
 
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


...put some description here...
Returns the localized name of the record.
</desc>
</desc>


Line 15: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
VCOMError FC_GetRecordLocalizedName(MCObjectHandle hFormat, TXString& outName);
VCOMError IFC_GetRecordLocalizedName(MCObjectHandle hFormat, TXString& outName);
</funcDef>
</funcDef>
</def>
</def>
Line 25: Line 25:
hFormat
hFormat
MCObjectHandle
MCObjectHandle
no info.
Handle to the record.
</line>
</line>
<line>
<line>
outName
outName
TXString
TXString
no info.
Out parameter for the result.
</line>
</line>
</lineList>
</lineList>
Line 44: Line 44:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 71: Line 67:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Vectorworks 2019
</version>
</version>



Revision as of 11:13, 6 March 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Returns the localized name of the record.

VCOMError IFC_GetRecordLocalizedName(
MCObjectHandle hFormat,
TXString& outName);

Parameters

hFormat MCObjectHandle Handle to the record.
outName TXString Out parameter for the result.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Vectorworks 2019