VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetPsetsForIFCType

From Vectorworks Developer
Revision as of 12:34, 6 August 2018 by NBeshevliev (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the applicable Property Sets for that IfcType and the attached from IFC Data Mapping.

VCOMError IFC_GetPsetsForIFCType(
const TXString& strIfcType,
std::vector<TXString>& outArrPsetsForType);

Parameters

strIfcType TXString IfcType name.
outArrPsetsForType std::vector<TXString> Property Sets for the IfcType.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019.