VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetPsetsForIFCType: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Returns the applicable Property Sets for that IfcType and the attached from IFC Data Mapping.
</desc>
</desc>


Line 25: Line 25:
strIfcType
strIfcType
TXString
TXString
no info.
IfcType name.
</line>
</line>
<line>
<line>
outArrPsetsForType
outArrPsetsForType
std::vector<TXString>
std::vector<TXString>
no info.
Property Sets for the IfcType.
</line>
</line>
</lineList>
</lineList>
Line 44: Line 44:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 71: Line 67:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2019.
</version>
</version>



Latest revision as of 12:34, 6 August 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the applicable Property Sets for that IfcType and the attached from IFC Data Mapping.

VCOMError IFC_GetPsetsForIFCType(
const TXString& strIfcType,
std::vector<TXString>& outArrPsetsForType);

Parameters

strIfcType TXString IfcType name.
outArrPsetsForType std::vector<TXString> Property Sets for the IfcType.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019.