VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetPsetProp2: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationVCOM|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <...")
 
No edit summary
Line 50: Line 50:
outMap
outMap
short
short
no info.
For more info: [[VCOM:VectorWorks:IFCLib:IFCEnumerations|IFC Enumerations]]
</line>
</line>
</lineList>
</lineList>

Revision as of 13:16, 3 April 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

...put some description here...

VCOMError IFC_GetPsetProp2(
MCObjectHandle hObject,
const TXString& strIfcPsetName,
const TXString& strIfcPropName,
TXString& outStrIfcPropValue,
short& iType,
short& outMap);

Parameters

hObject MCObjectHandle no info.
strIfcPsetName TXString no info.
strIfcPropName TXString no info.
outStrIfcPropValue TXString no info.
iType short no info.
outMap short For more info: IFC Enumerations

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.