VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetPsetProp2: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Returns the property value from a property set.
</desc>
</desc>


Line 25: Line 25:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
Handle to object.
</line>
</line>
<line>
<line>
strIfcPsetName
strIfcPsetName
TXString
TXString
no info.
Property set name.
</line>
</line>
<line>
<line>
strIfcPropName
strIfcPropName
TXString
TXString
no info.
Property name.
</line>
</line>
<line>
<line>
outStrIfcPropValue
outStrIfcPropValue
TXString
TXString
no info.
Returns the property value.
</line>
</line>
<line>
<line>
iType
iType
short
short
no info.
Retruns the property type. Possible values:  UNKNOWN(0), IDENTIFIER(1), DOUBLE(2); BOOLEAN(3); INTEGER(4); NUMBER(5); LOGICAL(6); STRING(7); ENUMERATION(8); SELECT(9).
</line>
</line>
<line>
<line>
outMap
outMap
short
short
For more info: [[VCOM:VectorWorks:IFCLib:IFCEnumerations|IFC Enumerations]]
Returns the source for the value. Possible values: eNotSet(-1); eFromInstance(0); eFromMapping(1). For more info: [[VCOM:VectorWorks:IFCLib:IFCEnumerations|IFC Enumerations]].
</line>
</line>
</lineList>
</lineList>
Line 64: Line 64:
kVCOMError_NoError
kVCOMError_NoError
The function succeeded. No Error!
The function succeeded. No Error!
</line>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the function.
</line>
</line>
<line>
<line>
Line 78: Line 74:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Note that this function returns only property values from properties. For values from Entities please use [[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetEntityProp2|IFC_GetEntityProp2]].
Use this function via global pointer gIFC.  
Use this function via global pointer gIFC.  
</remark>  
</remark>  
Line 87: Line 86:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetEntityProp2|IFC_GetEntityProp2]]
</seeAlso>
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2017.
</version>
</version>



Latest revision as of 15:26, 23 July 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the property value from a property set.

VCOMError IFC_GetPsetProp2(
MCObjectHandle hObject,
const TXString& strIfcPsetName,
const TXString& strIfcPropName,
TXString& outStrIfcPropValue,
short& iType,
short& outMap);

Parameters

hObject MCObjectHandle Handle to object.
strIfcPsetName TXString Property set name.
strIfcPropName TXString Property name.
outStrIfcPropValue TXString Returns the property value.
iType short Retruns the property type. Possible values: UNKNOWN(0), IDENTIFIER(1), DOUBLE(2); BOOLEAN(3); INTEGER(4); NUMBER(5); LOGICAL(6); STRING(7); ENUMERATION(8); SELECT(9).
outMap short Returns the source for the value. Possible values: eNotSet(-1); eFromInstance(0); eFromMapping(1). For more info: IFC Enumerations.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Note that this function returns only property values from properties. For values from Entities please use IFC_GetEntityProp2.


Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017.

See Also

IFC_GetEntityProp2

[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetEntityProp2|IFC_GetEntityProp2]]