VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetPsetProp

From Vectorworks Developer
Revision as of 14:59, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

...put some description here...

virtual VCOMErrorVCOM_CALLTYPE IFC_GetPsetProp(
MCObjectHandle hObject,
const TXString& strIfcPsetName,
const TXString& strIfcPropName,
TXString& strIfcPropValue,
short& iType) = 0;

Parameters

hObject MCObjectHandle no info.
strIfcPsetName const SDK:TXString& no info.
strIfcPropName const SDK:TXString& no info.
strIfcPropValue SDK:TXString& no info.
iType short& no info.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.