VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetPsetProp: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(2 intermediate revisions by 2 users not shown)
Line 1: Line 1:
{{LocationMain|category=LocationVCOM|specific=}}
{{LocationMain|category=LocationVCOM|specific=}}
__TOC__
<vwDoc>
<vwDoc>
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
namespace <code>VectorWorks::IFCLib</code>
<font color="red">DO NOT USE THIS FUNCTION.</font> It is not supported.
 
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
 
...put some description here...
</desc>
</desc>
-----------------------------------------------------------------------------------------------------------
<def>
<funcDef lang="cpp">
VCOMError IFC_GetPsetProp(MCObjectHandle hObject, const TXString& strIfcPsetName, const TXString& strIfcPropName, TXString& strIfcPropValue, short& iType);
</funcDef>
</def>
-----------------------------------------------------------------------------------------------------------
<params>
<lineList ident=1>
<line>
hObject
MCObjectHandle
no info.
</line>
<line>
strIfcPsetName
TXString
no info.
</line>
<line>
strIfcPropName
TXString
no info.
</line>
<line>
strIfcPropValue
TXString
no info.
</line>
<line>
iType
short
no info.
</line>
</lineList>
</params>
-----------------------------------------------------------------------------------------------------------
<return>
Uses standard [[VCOM:VCOMError|VCOM Error Reporting]].
Return value meaning:
<lineList ident=1>
<line>
kVCOMError_NotInitialized
Bad VCOM instance used to call the fuction.
</line>
<line>
kVCOMError_Failed
Routine failed.
</line>
</lineList>
</return>
-----------------------------------------------------------------------------------------------------------
<remark>
</remark>
-----------------------------------------------------------------------------------------------------------
<sample>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetPsetProp2|IFC_GetPsetProp2]]
</seeAlso>
</seeAlso>
-----------------------------------------------------------------------------------------------------------
<version>
</version>
</vwDoc>
</vwDoc>
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|IFC_GetPsetProp]]

Latest revision as of 12:10, 27 August 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

DO NOT USE THIS FUNCTION. It is not supported.

See Also

IFC_GetPsetProp2

[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetPsetProp2|IFC_GetPsetProp2]]