VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetPsetName: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Returns the name of the Property Set (SPet).
</desc>
</desc>


Line 25: Line 25:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
Handle to the object.
</line>
</line>
<line>
<line>
index
index
short
short
no info.
Index of the attached PSet.
</line>
</line>
<line>
<line>
strIfcPsetName
strIfcPsetName
TXString
TXString
no info.
Out parameter, the name of the PSet.
</line>
</line>
</lineList>
</lineList>
Line 47: Line 47:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
kVCOMError_NotInitialized
kVCOMError_NoError
Bad VCOM instance used to call the fuction.
The function succeeded. No Error!
</line>
</line>
<line>
<line>
Line 59: Line 59:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Use this function via global pointer gIFC.
</remark>
</remark>


Line 71: Line 72:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 2009
</version>
</version>



Latest revision as of 07:38, 27 August 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the name of the Property Set (SPet).

VCOMError IFC_GetPsetName(
MCObjectHandle hObject,
short index,
TXString& strIfcPsetName);

Parameters

hObject MCObjectHandle Handle to the object.
index short Index of the attached PSet.
strIfcPsetName TXString Out parameter, the name of the PSet.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2009