VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetPsetInfoAt

From Vectorworks Developer
Revision as of 11:22, 3 August 2018 by KGoranov (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the property set name, if it is attached and where from (mapping or record).

VCOMError IFC_GetPsetInfoAt(
MCObjectHandle hObject,
bool bAllPsets,
short index,
TXString& outIfcPsetName,
short& outType);

Parameters

hObject MCObjectHandle Handle to object.
bAllPsets bool Boolean that defines whether customPsets are to be checked.
index short Index that defines the pset position.
outIfcPsetName TXString Returns the property set name
outType short Returns the index that defines the state of the Pset. Possible values are: -2 (pset forbidden from mapping, NOT attached in record), -1 (pset forbidden from mapping, but attached in record), 0 (pset NOT attached), 1 (pset attached from record), 2 (pset attached from mapping).

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2018.